Description: Fix Lintian hardening errors caused by flags not being passed to compiler,
use debhelper compiler flags
Author: Dave Hibberd <d@vehibberd.com>
Last-Update: 2017-08-22

--- a/Makefile.in
+++ b/Makefile.in
@@ -3,8 +3,11 @@
 CC = gcc
 LD = gcc
 # CFLAGS = -O2 -g -s -Wno-unused-result -Wstrict-prototypes
-CFLAGS = -DUNIX -g3 -DDEBUG
-LDFLAGS =
+# CFLAGS = -DUNIX -g3 -DDEBUG
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
 LIBS = -lax25 -lax25io
 
 include Makefile.include
@@ -24,7 +27,7 @@
 DIGI_OBJS =		$(DIGI_SRC:.c=.o)
 CALIBRATE_OBJS =	$(CALIBRATE_SRC:.c=.o)
 .c.o:
-	$(CC) $(CFLAGS) -c $<
+	$(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(CXXFLAGS) -c $<
 
 install: installbin installman installhelp installconf
 	install -b -m 755    -D -d	$(VAR_DIR)